Solutions to Common Problems

From NSB App Studio
Jump to: navigation, search

Only the first few are actually common - there isn't much that goes wrong.

My app gets an error box when run on a device, or it does not run in Airplane mode.

CacheError.png

This means it is trying to use a file that has not been cached on the device. In Project Properties, check that all the images and files are listed in the manifest. In certain cases it could mean the application cache on your device is corrupt.

  1. Open a new Chrome window on the desktop.
  2. Open the Chrome Debugger by clicking F12 on the keyboard. (option command J on Mac OS)
  3. Enter the URL of your program on your deploy site and hit enter.
  4. In the message panel at the bottom of the screen, you will see the files it caches.
  5. Make sure all the files your app uses appear without errors.
  6. Use Check Deployment on the Run menu to check your server. If it is incorrect, see Setting up your server for manifest files.
  7. Check to make sure that Private Browsing is not turned on.
  8. Make sure Cookies are not turned off in your browser.
  9. If possible, use the Chrome browser on Android devices (not the older Android browser).
  10. Try clearing the cache of your browser. On iOS, do this by closing all tabs in Safari, then opening Settings...Safari. First clear history and your cache. Then go to Advanced...Website Data...Edit...wipe out nsbapp.com (or the name of your server). Finally restart your device.
  11. Make sure the server you loaded from is online.

To suppress this message, add this line of code in Sub Main()

  window.applicationCache.removeEventListener("error", NSB.oncache, False)

Use this statement with extreme caution: in nearly every case, the Error message is reporting something that needs to be fixed. It can be reenabled by removing the line above, or alternatively using an error handler of your own design with this code:

  window.applicationCache.addEventListener("error", myFunc, False)

where myFunc is a function in your own code.

When I try to reset my Volt password I get a message "Unauthorized". What do I do?

Account activations expire after an hour. Fortunately, getting a new link is easy:

  1. Navigate to https://dashboard.voltcloud.io/.
  2. Click on “Forgot your password?”
  3. Enter in the email address you registered with.
  4. A new email should arrive shortly.

"Chrome can’t find jquery.min.map"

It’s not one you need to worry about. It only happens when you are running with the Chrome Debugger open. It’s complaining that it does not have the extra files it needs to display the jQuery source code properly. Since it is very unlikely that you will have any need to look at that code, it doesn’t matter.

If it really bugs you, you can go into the Debugger Preferences and turn off the warning. The setting to turn off is “Enable Source Maps”.

There is more info here.

When I run my app on the desktop, I just get a blank screen.

Your program is probably getting an error. Hit F12 (option-shift-j on Mac) to open the Chrome Debugger (assuming you are using Windows Chrome). You'll see the error.

Parts of the IDE are distorted or do not pop up properly in Windows.

Check if you are using an Aero theme on your desktop. Try switching to a non Aero theme.

The background on the Design Screen is blank.

  • If you are running on a Mac using Parallels, make sure that 'My Documents' in Windows is not mapped to its Mac equivalent.
  • If you installed to a server, move \Documents\NS Basic Samples\ to your local system. Write access is required to that directory.

In the Code Window, I cannot enter ', " or extended characters

If you are running on Mac OS, do not use "USA International PC" as your keyboard layout. It uses the single quote character (') to start entering some extended characters. The single quote is important in the code window to quote strings and start comments.

I'm running Anti Virus software. What could go wrong?

Norton: Blocks installation with a WS.Reputation.1 message. If an executable is unknown to Norton (perhaps it is new), it automatically quarantines it. Since we update AppStudio frequently, this happens occasionally. Just take it out of the quarantine and it will work. We have contacted Norton about this - they say they have removed the block.

McAfee: AppStudio runs slowly. McAfee has a Real Time Scanning option that intercepts every system call that the apps on your system make. On slower computers, this feature can bring the system to a crawl. Disable this feature to solve the problem.

Kaspersky: AppStudio does not run. We're not sure if this Kaspersky related, or a corrupted system which caused this one. The solution was to

  1. sfc /scannow, which resulted in the message that there were files to be repaired.
  2. update NVIDIA display driver of Jan 2013.

In the Design Screen, some of my controls do not appear

Are you using an HTMLview control anywhere in your project? If so, check that the innerHTML value is valid and complete HTML. For example, forgetting to match a <div> or <font> tag with a matching </div> or </font> tag will cause other problems in your project.

QuotaExceededError

The full message is "QuotaExceededError: DOM Exception 22: An attempt was made to add something to storage that exceeded the quota.". It will show up in the debugger console. This can happen on an iOS device with Safari in Private mode. When in Private mode, Safari is not allowed to write to localStorage. Have the user turn Private mode off.

TypeError: must be string without null bytes or None, not str

The full message ends with this:

   File "C:\Files\nsbx\Setup\build\AppStudio\out00-PYZ.pyz\mimetypes", 
line 254, in read_windows_registry

TypeError: must be string without null bytes or None, not str

You probably have corrupted registry entries from malware. Run this utility: https://technet.microsoft.com/en-us/sysinternals/bb897448.aspx

It needs to be run on HKLM, HKCU and HKCR. When complete, export the entries which are reported and delete them.